SecureFax Portal Issues

Incident Report for OneCloud

Resolved

This incident has been resolved. OneCloud engineers identified and fixed the root cause affecting the SecureFax Portal, and we have confirmed through monitoring that login functionality and the ability to view sent and received faxes have been fully restored. If you continue to experience any issues, please log out and back in to the portal.
Posted Jul 17, 2026 - 14:03 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 17, 2026 - 13:43 UTC

Monitoring

OneCloud engineers have identified the root cause and implemented a fix. We continue to monitor the situation. Users may need to logout and back in to the portal.
Posted Jul 17, 2026 - 13:32 UTC

Investigating

We are currently investigating an issue with the SecureFax Portal affecting users ability to login and view sent or received faxes.
Posted Jul 17, 2026 - 13:09 UTC
This incident affected: SecureFax (Portal).