OneCloud Connect Unreachable

Incident Report for OneCloud

Postmortem

Authentication Access Disruption – December 3, 2024

Dear OneCloud Connect Customer,

On December 3, 2024, OneCloud Connect experienced a temporary disruption that affected the ability of some users to log into the platform. We know how important reliable access is to your business, and we want to share a clear explanation of what happened, how it was resolved, and what we are doing to strengthen our systems moving forward.

What Happened

During the morning hours, a component responsible for handling short-term login information began operating incorrectly. As a result:

  • Some users were unable to log into OneCloud Connect
  • Desktop applications reloaded more frequently than normal
  • Push notifications were delayed or did not appear

It’s important to note that calling and messaging services continued to function throughout this event, including call forwarding and voicemail routing.

Timeline of Events (Eastern Time)

  • 10:53 AM – Our team detected abnormal activity affecting logins
  • 10:58 AM – Investigation began and a public status update was issued
  • 11:25 AM – The cause of the issue was identified
  • 11:32 AM – A fix was applied and recovery monitoring began
  • 11:40 AM – Full service functionality was confirmed

The total duration of the disruption was approximately 47 minutes.

What Caused the Issue

The disruption was traced to the system that temporarily stores login information. This component ran out of available memory, preventing new login sessions from being created and triggering the related app and notification issues. This impact was limited to the OneCloud Connect application.

How We Resolved It

Our engineering team acted immediately to restore service. Their actions included:

  • Increasing available memory in the login caching system
  • Optimizing memory usage to stabilize performance
  • Validating full platform recovery and monitoring for additional issues

All services were confirmed to be fully operational by 11:40 AM.

What We’re Doing to Prevent This in the Future

We take platform reliability seriously. To strengthen the system and reduce the likelihood of a similar incident, we’ve put several improvements in place and have additional upgrades planned.

Completed Enhancements

  • Expanded caching capacity by 300%
  • Improved system monitoring and early-warning alerts
  • Added new safeguards to prevent memory-related disruptions

Upcoming System Improvements

  • Auto-scaling capabilities for the caching system (December 2025)
  • Enhanced protection mechanisms designed to isolate and contain system issues (December 2025)
  • Updated session management architecture for greater efficiency and resilience (Q1 2026)
  • Ongoing stress testing and capacity reviews

Our Commitment to You

We sincerely apologize for the inconvenience and interruption this caused. We understand the importance of consistent and dependable access to OneCloud Connect, and we are dedicated to delivering the level of reliability you expect.

Our team will continue to closely monitor system performance and make proactive enhancements to ensure your communications run smoothly and without interruption.

Need Assistance?

If you are still experiencing issues or would like additional information about this incident, our support team is available and ready to help at support@onecloud.com.

Thank you for your trust in OneCloud Connect and for your continued partnership.

Posted Dec 05, 2025 - 20:57 UTC

Resolved

All services are now operating normally.
Posted Dec 03, 2025 - 19:08 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 03, 2025 - 16:56 UTC

Monitoring

OneCloud Engineers have identified the issue and pushed a fix. We continue to monitor the issue.

If you continue to experience an issue please contact support@onecloud.com
Posted Dec 03, 2025 - 16:56 UTC

Investigating

OneCloud Connect is currently unavailable for some users. We are actively working to resolve this issue and apologize for any inconvenience.

Affected users can access the webphone using either method below:
• Direct link: https://myonecloud.com/webphone
• Via portal: Log into https://myonecloud.com and select "WebPhone" from the top-right menu

We will provide updates as more information becomes available.
Posted Dec 03, 2025 - 16:14 UTC
This incident affected: OneCloud Connect (Meetings, Recordings).